17

http://www.numenity.org

"The live webcast requires the Flash player 9 plugin to be installed to view the video stream. For a number of reasons, I’m less than happy about requiring the use of a proprietary piece of software on the client end to experience the webcast."

Full story »
can.axis's picture
Created by can.axis 7 years 1 week ago – Made popular 7 years 1 week ago
Category: End User   Tags: